Invision Byte: Bump Up Topics - Invision Byte

Jump to content

Welcome to Invision Byte

Welcome to Invision Byte, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information. Take advantage of it immediately, Register Now or Sign In.

  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Purchase one of the products available and quickly receive support for it!
  • View and use the shoutbox to communicate
  • Get your own profile and make new friends
  • Customize your experience here
Guest Message by DevFuse
  • 3 Pages +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

Bump Up Topics

#41
User is offline   nook 

  • n00b
  • Pip
  • Group: Members
  • Posts: 4
  • Joined: 02-December 15
  • IP.Board:N/A
  • Current Mood: Current Mood: None Chosen

View Postterabyte, on 05 December 2015 - 05:24 PM, said:

You mean you want to bump the START DATE of the topic instead of the LAST POST date?

I would like just it work with that two sorting by date methods, I got default sorting by date of create topic and I see it's not bumping on that view

I need also an option to bump when post is on second page instead of bumping after some time.

I have ipb 3,4.

I can donate 10$. Useful plugin btw I want it work in classifieds forums ☺

GreetingsPs on print screen I see warn status in posts, where to download this mod? I have some custom jobs also if you are interested email me.

This post has been edited by terabyte: 25 January 2016 - 04:40 PM
Reason for edit: Fixed BR tags

0

#42
User is offline   nook 

  • n00b
  • Pip
  • Group: Members
  • Posts: 4
  • Joined: 02-December 15
  • IP.Board:N/A
  • Current Mood: Current Mood: None Chosen
hard to catch you :D
0

#43
User is offline   nook 

  • n00b
  • Pip
  • Group: Members
  • Posts: 4
  • Joined: 02-December 15
  • IP.Board:N/A
  • Current Mood: Current Mood: None Chosen
option to update date of create would be imba to this... :btw. :]
0

#44
User is offline   Baboulinet54 

  • n00b
  • Pip
  • Group: Members
  • Posts: 4
  • Joined: 25-January 16
  • IP.Board:3.4.x
  • Current Mood: Current Mood: None Chosen
Hello,Thank you for this nice plugin. I installed this hook on a forum I'm managing. It works perfectly on the standard view but the button not visible on the mobile version (both default IP.Board themes). Is there something I missed during the install or is there something else to do to have it working on the mobile version please?
0

#45
User is offline   terabyte 

  • Administrator
  • PipPipPipPipPipPipPipPip
  • Group: Management
  • Posts: 8,907
  • Joined: 30-September 07
  • Location:Italy
  • IP.Board:3.1.x
  • Current Mood: Current Mood: Insomnious

View Postnook, on 06 December 2015 - 05:23 AM, said:

I would like just it work with that two sorting by date methods, I got default sorting by date of create topic and I see it's not bumping on that view

I need also an option to bump when post is on second page instead of bumping after some time.

I have ipb 3,4.

I can donate 10$. Useful plugin btw I want it work in classifieds forums ☺

GreetingsPs on print screen I see warn status in posts, where to download this mod? I have some custom jobs also if you are interested email me.

Sorry for not replying earlier, I totally missed your replies.

Updating the start date too would cause trouble with some sorting functions of the forum, I remember looking into it for someone else quite a long while ago and in the end I advised against it.

As for the topic being on the second page, would that be based on the default forum filter/order? Or maybe on a specific one setup in a new option?


View PostBaboulinet54, on 25 January 2016 - 02:40 PM, said:

Hello,Thank you for this nice plugin. I installed this hook on a forum I'm managing. It works perfectly on the standard view but the button not visible on the mobile version (both default IP.Board themes). Is there something I missed during the install or is there something else to do to have it working on the mobile version please?

Unfortunately this modification is not meant to be available on the mobile skin. I have fixed this in the new version available for the IPS Suite 4.x and I have no plans to update the 3.x version anymore at this point :(
Board Rules - Available Products - Products Faqs - Need a Custom Work?


* Don't PM me for support, post in the forum or submit a ticket from the client area! *
0

#46
User is offline   Baboulinet54 

  • n00b
  • Pip
  • Group: Members
  • Posts: 4
  • Joined: 25-January 16
  • IP.Board:3.4.x
  • Current Mood: Current Mood: None Chosen
Hello,As I saw in the hook.xml file that there is a template added to the mobile theme (v2.0.2, lines 768 to 837), I assumed it was added on the mobile theme as well. Now I know why it's not display. I will find a way to add it in the mobile version then. Thank you for your help. :)
0

#47
User is offline   terabyte 

  • Administrator
  • PipPipPipPipPipPipPipPip
  • Group: Management
  • Posts: 8,907
  • Joined: 30-September 07
  • Location:Italy
  • IP.Board:3.1.x
  • Current Mood: Current Mood: Insomnious

View PostBaboulinet54, on 25 January 2016 - 03:48 PM, said:

Hello,As I saw in the hook.xml file that there is a template added to the mobile theme (v2.0.2, lines 768 to 837), I assumed it was added on the mobile theme as well. Now I know why it's not display. I will find a way to add it in the mobile version then. Thank you for your help. :)


Ops, you are right. When I replied earlier I was looking at the IPB 3.3 version (which is still 2.0.1) and not the 2.0.2 one. It does seem I have added support for the mobile skin on IPB 3.4 (and I completely forgot about it :laughing: ).

After taking a look at it the issue is a bug with IP.Board itself, in the topicViewTemplate for the mobile skin they have the closedButton hook twice and that makes the code not understand where the template should be added, thus skipping it. I doubt IPS is going to fix this for any future 3.4.10 version (if there will ever be one, maybe security patches only).

To fix the issue yourself open the topicViewTemplate in the mobile skin and search for this code:
			<if test="closedButton:|:$displayData['reply_button']['image'] == 'locked'">
				<if test="closedButtonLink:|:$displayData['reply_button']['url']">


You will find TWO instances of this code and you MUST change only the second one to this code instead:
			<if test="closedButtonBottom:|:$displayData['reply_button']['image'] == 'locked'">
				<if test="closedButtonBottomLink:|:$displayData['reply_button']['url']">


Save the template edit and you're done. After this the button should properly start showing at the top of the page.
Board Rules - Available Products - Products Faqs - Need a Custom Work?


* Don't PM me for support, post in the forum or submit a ticket from the client area! *
0

#48
User is offline   Baboulinet54 

  • n00b
  • Pip
  • Group: Members
  • Posts: 4
  • Joined: 25-January 16
  • IP.Board:3.4.x
  • Current Mood: Current Mood: None Chosen
Amazing support. It fixed the issue. Thanks a lot again.
0

#49
User is offline   terabyte 

  • Administrator
  • PipPipPipPipPipPipPipPip
  • Group: Management
  • Posts: 8,907
  • Joined: 30-September 07
  • Location:Italy
  • IP.Board:3.1.x
  • Current Mood: Current Mood: Insomnious
You're welcome :cat:
Board Rules - Available Products - Products Faqs - Need a Custom Work?


* Don't PM me for support, post in the forum or submit a ticket from the client area! *
0

Share this topic:


  • 3 Pages +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users